This post has not been edited by the GamesBeat staff. Opinions by GamesBeat community writers do not necessarily reflect those of the staff.

I bought Bioshock 2 yesterday. Up until a half hour ago I was satisfied with the purchase.

I reached the first point where you fight a big sister. After a rather intense scuffle, with blaringly intense fiddle music that put me on edge in the background, I finally KOed the beast. I then sort of felt a little empty.

Killing it had no storyline payoff. For how much build up they made for this enemy type both in the pre release hype and the opening hours of the game itself they made the act of killing one amount to even less then killing a big daddy. It was just done.

After that I decided to hang it up for the night and tackle the game fresh in the morning. To try and distance myself from that dissapointment and continue tackling the story proper. When I booted the game up this morning, however, I noticed something strange.

The fiddle music from the big sister fight was back. I looked around frantically, thinking maybe I had forgotten to save after the fight and was in a mid fight save. Finding no big sister I eventually decided it was a glitch and moved on to the next area. Sure that the error in the game's music system would clear itself up.

It didn't.


I have been wandering the next section of the game for upwards of half an hour with no end to this goddamn music. Unstoppably intense, horribly repetitive, and replacing every bit of atomosphereic music that was supposed to be telling me what the mood the game was going for in each section was.

I can't focus on the simple act of scouring the levels and taking out the minor enemies that are being thrown at me because that screaming violin is constantly telling me "OH  MY GOD A BIG SISTER IS AROUND! LOOK OUT!"

So i tried saving and then loading it up again, hoping that the save system didn't keep the music status as part of it's file.

Sadly it did, no change in the music.

So then I turned off the game and restarted the entire system. Then loaded up the save. No change. Still the same music.

This screaming fiddle bullshit has to stop sometime right? I certainly hope so, because i'm fast learning that Bioshock's legendary atmosphere and sense of place is nothing without it's sound design. Replace all of that with the sound of a cat being assaulted with a garden weasel and the rest of the game becomes an annoying chore.

I certainly hope I don't have to restart the game entirely because of the sound designer's inability to error check his systems.